Inspire Education's news

BSB Training Package Update FAQ

0 Comments   Posted:   by

BSB Training Package Update FAQ

The BSB Training Package just had a massive update, and here’s what you need to know.

Big Changes in the Latest BSB Version 7.0

The Version 7.0 of the Business Services (BSB) Training Package affects a significant amount of business and management qualifications, including popular ones such as Leadership and Project Management Certificates and Diplomas.

Previously separate qualifications were streamlined and merged into a single one, which will then have specialisations. For example, the new BSB40120 Certificate IV in Business supersedes eight (8) qualifications, and now has nine (9) specialisations. Twenty (20) new units of competency are also introduced in the latest release.

Detailed info about the BSB training package update found on the National Register and PwC’s Skills for Australia.

How Does This Affect Me?

Here are some questions and answers on how the BSB Version 7.0 Update affects Inspire Education students and business courses:

 

Q: There is a new release (October 2020) of the BSB Training Package. Should I enrol now or wait until Inspire Education offers the latest qualifications?

A: Yes, you may still enrol in the superseded courses below. Successfully completing these courses within the 18-month teach out period means you will only need to do gap training for the units shared by the old and new versions.

These are superseded but equivalent to their newer versions, so there is no reason to delay your enrolment:

 

Q: I have already commenced my course. What qualification will I get once I finish?

A: You will still receive the Certificate or Diploma you are currently working on. The superseded versions will continue to be recognised as acceptable professional qualifications, as there is currently no legislative requirement to upgrade to the latest qualifications.

 

Q: I currently have the superseded qualification. How can I upgrade to the newer version?

A: You should be eligible for Credit Transfer for the equivalent units you have already completed. There may also be upgrade courses available that will identify and address gaps between the old and new qualifications.

 

Q: Will my course still be valid even if I don’t want to transition to the new course?

A: Yes, your course remains active, but you must successfully complete it before the teach out period ends. The superseded qualifications also remain valid; there is currently no legislative requirement to upgrade to the latest qualification.

 

Q: When will you deliver the latest versions of these courses?

A: We are currently working on them. We will continue to provide regular communication about the development of these new courses, including progress updates to all our active students in the superseded courses.

 

Q: I currently hold an older version of the course I want to enrol in. Should I upgrade now or wait for the newer qualification?

A: There is no reason to delay your enrolment, so you may enrol now. You will be eligible for Credit Transfer for all equivalent units included in your previous qualification. If there are any gaps between your older course and the course you want to enrol in, we will offer a means to bridge those gaps, either via Recognition of Prior Learning (RPL) or gap coursework.

The following two tabs change content below.

Joshua

Latest posts by Joshua (see all)

You can skip to the end and leave a response. Pinging is currently not allowed.

Leave a Reply

Whoops!!

Could you please amend the form? We’ve highlighted the problem(s) for you...